Problems using pnpm


I’m working on multiple frontend apps in a monorepo where we are using pnpm workspaces and using turborepo to manage the builds.

What I’m having trouble with is using pnpm as the package manager since turborepo runs commands where it expects the pnpm bin to be available without having to use corepack.

This is the error I’m getting:

W: @kps/booking:build: ERROR: command finished with error: exec: "pnpm": executable file not found in $PATH
W: exec: "pnpm": executable file not found in $PATH

I’ve tried installing pnpm with corepack so that it’s available in the path but this creates other issues since the filesystem where it tries to place the bin files is read-only.

Internal Error: EROFS: read-only file system, symlink '../lib/node_modules/corepack/dist/pnpm.js' -> '/usr/bin/pnpm'
Error: EROFS: read-only file system, symlink '../lib/node_modules/corepack/dist/pnpm.js' -> '/usr/bin/pnpm'
Preparing pnpm@7.5.2 for immediate activation...
W: dash: 3: pnpm: not found
W: dash: 4: pnpm: not found

I’m thinking about just changing to NPM instead, but if we can keep using pnpm then that would be the preferred option.

I hope someone can help out with this, thanks!

Hi @normysan, have you tried this in your or your .platform/applications.yaml:

        pnpm: "*"

Good luck!

Thanks, this worked great. I was so focused on getting the corepack method to work since this is how Yarn is recommended to be installed in the docs :slight_smile:

1 Like