Anyone managed to install libvips on

I’d love to use libvips for image processing instead of imagemagick or gd in my PHP projects.

I guess, I’d need to install the library in my build hook and add the custom php extension as described in your docs.

Here is what I’ve tried so far:

Unfortunately, my builds got stuck and failed after 60min, while trying to brew gcc.
Here are the last lines I see in the build logs:

==> Installing gcc
    ==> ../configure --prefix=/app/.linuxbrew/Cellar/gcc/11.1.0_1 --libdir=/app/.linuxbrew/Cellar/gcc/11.1.0_1/lib/gcc/11 --disable-nls --enable-checking=release --enable-languages=c,c++,objc,obj-c++,fortran,d --program-suffix=-11 --with-gmp=/app/.linuxbrew/opt/gmp --with-mpfr=/app/.linuxbrew/opt/mpfr --with-mpc=/app/.linuxbrew/opt/libmpc --with-isl=/app/.linuxbrew/opt/isl --with-zstd=/app/.linuxbrew/opt/zstd --with-pkgversion=Homebrew GCC 11.1.0_1 --with-bugurl= --enable-libphobos --with-boot-ldflags=-static-libstdc++ -static-libgcc  --disable-multilib
    ==> make
  E: The operation was killed because it ran for longer than 60 minutes.
E: Error: Unable to build application, aborting.

I’ve tried this many times, not just ones.
Anyone here managed to brew packages successfully or faced something similar?
I am very thankful for any hint!

The problem is that compiling gcc takes a long time. Can you try with just vips?